SimcenterX issue is resolved - EU

Incident Report for Siemens Service Status

Resolved

The issue with SimcenterX has been resolved.
Posted Nov 25, 2025 - 11:15 UTC

Investigating

We are currently having issues with SimcenterX. Our development team is looking into the incident.
We’ll send an update when the issue is resolved. Check updates: https://status.sw.siemens.com/
Posted Nov 25, 2025 - 11:01 UTC
This incident affected: Europe (Simcenter X).