Connect issues resolved - EU

Incident Report for Siemens Service

Resolved

The issue with Connect has been resolved.
Posted Feb 23, 2026 - 20:18 UTC

Update

We are continuing to investigate this issue.
Posted Feb 23, 2026 - 19:40 UTC

Update

We are continuing to investigate this issue.
Posted Feb 23, 2026 - 18:35 UTC

Update

We are currently having issues with Connect. Our development team is looking into the incident.

We’ll send an update when the issue is resolved. Check updates: https://status.sw.siemens.com/
Posted Feb 23, 2026 - 15:27 UTC

Investigating

We are currently having issues with Connect. Our development team is looking into the incident.

We’ll send an update when the issue is resolved. Check updates: https://status.sw.siemens.com/
Posted Feb 23, 2026 - 15:08 UTC
This incident affected: Europe (Connect).